Bricked my H501S FPV1

Post Reply
Posts: 1
Joined: Sat May 16, 2020 10:42 am

Bricked my H501S FPV1

Post by 1533248570925pT » Tue May 04, 2021 3:12 pm

Haven't used it for a while, didn't know what the model/version was, so I installed the wrong firmware via my laptop. Now it no longer turns on, just a black screen. Did I kill it?

Posts: 5
Joined: Thu Jun 18, 2020 7:03 am
Location: Extremadura

Re: Bricked my H501S FPV1

Post by me_6da5fF5lBp » Wed Jun 02, 2021 3:58 am

Bueno días: Prueba a instalas de nuevo.

Posts: 3
Joined: Fri Aug 20, 2021 11:08 am

Re: Bricked my H501S FPV1

Post by MaxMann » Fri Aug 20, 2021 11:20 am

I did the same thing & I'm in the same boat!!! I did some homework on this paltry dilemma and this is what I discovered.
This H906A (FPV1) transmitter was made by a 3rd party company. This company changed out the LCD display design, well in order for this new display to function, they had to come up with their own firmware for it. You are going to need
v1.31.19 It is the only one that will work with these 3rd party frankenstein-ed transmitters
WHat's worse is Hubsan doesn't have this nor technically even owns it. I have yet to find this single version (v1.31.19) ANYWHERE!!!
I used to like Hubsan, but after realizing when a customer has more information about a company than a supposed "Representative" does, there's something seriously wrong with said Company's organizational skills. Pretty sad.
If there's anyone out there that has this firmware, PLEASE post!!!

Posts: 2
Joined: Mon Aug 23, 2021 11:11 pm

Re: Bricked my H501S FPV1

Post by zambrabo48 » Mon Aug 23, 2021 11:24 pm

brother we are in the same comments you managed to get the necessary firmware?

Posts: 1
Joined: Tue Dec 28, 2021 12:22 am

Re: Bricked my H501S FPV1

Post by eur_5401bPCozm » Mon Jan 03, 2022 6:06 am

Hi guys.
I know this is a bit of an old post now but i thought i'd let you know about my Bricked 501S. Similar to the original poster on here, i'd left my Hubsan for a while & it was having none of it when i tried to fire it up.
So i reflashed the firmware, hoping that would cure my problems. If anything, it made them worse. I could'nt even get my bird to light up, let alone bind. I tried all 3 controllers that i have (bought a job lot off ebay a couple of years back) but nothing. So i decided to flash the H501S controller with the upto date FC, RX & TX. Anyway, what kept puzzling me was, when i'd got the controller connected to my pc, put it in upgrade mode & then connected my birds battery, the upgrade prog said it was connected & would i like to upgrade, but every time i clicked upgrade, the status bar would only go about 1/3 of the way & then it would give me a 'time out' error.
I tried & tried & tried, but still no joy. I wondered if my FC had gone, so took one out of one of my other birds & tried again. Exactly the same issue. This was driving me bonkers.
By chance, i'd forgot to take the micro USB lead out of the bird at one attempt & noticed my pc would give a 'USB disconnect' sound. So i knew the board was working. So i went through the process of connecting my controller to my pc, put it in upgrade mode, loaded the firmware i wanted to use & then connected my birds battery. This is when the EUREKA MOMENT happened. My bird slipped out of my hand & ended up nose down on my controllers lcd. Low & behold, the progress bar on the upgrade tool went to 2/3's but then timed out again.
One more attempt but this time i held my bird nose down on the lcd & BINGO. the upgrade loaded, the progress bar went all the way & then told me the upgrade was a success.
So i then disconnected everything & put the controller in to bind mode, connect ed the battery to my bird & BINGO AGAIN. The bind process worked. The LED's on my bird flashed like they'd never flashed before & now she is back to full working order :-)

The whole point to my post is just to say, don't give up if you feel you may have bricked yours. It seems you have to hold your bird right up against your controller to get it to connect when loading the firmware.
Once this wind has died down here, i'm taking my bird out again :-)
Gazza :D

Post Reply