Zino 2 update fail

Post Reply
Posts: 1
Joined: Sun Jul 11, 2021 6:24 am
Location: Denmark

Zino 2 update fail

Post by me_5438cDeu2G » Sun Jul 11, 2021 6:31 am

I have bought a Zino 2 this week, but I have not flown yet.

My Zino 2 has firmware V1.1.5 and the APP forces me to upgrade to V1.2.5. I have tried to update several times, but the update stops everytime. After 10 minutes the Zino 2 beeps sequential and drains the Transmitter for all battery power in about 45 minutes.

Next I udated via USB cable to the Zino 2 and used the Ambrella EVK Firmware downloader. The update finished succesfull, but the APP still want me to upgrade. I tried again several times to upgrade via APP, but nu luck, it keeps stopping the update.

I formatted the SD card (U3) 64GB as FAT32 - no difference.

Please help needed. It is frustrating to buy a Zino 2 and get stucked in update problems, and no flying as result.

Greetings from Denmark

Posts: 3
Joined: Mon Aug 24, 2020 6:05 am

Re: Zino 2 update fail

Post by me_83548XonUP » Sun Aug 08, 2021 4:40 am

Dear Hubsan Team,
I have a Zino 2 and I was forced to Update Firmware.
I followed the instructions to do it OTA, but never goes over 99%. I tried several times without success.
By doing with Ambarella it' supposed to be succesfully Updated, but on the hubsan x2 app, the same prompt message appears, that an update is needed.
It's my drone now bricked?.
Hubsan team:what solution do you propose to me?

Kind regards

Posts: 1
Joined: Thu Mar 25, 2021 8:27 pm

Re: Zino 2 update fail

Post by me_a6acaoTeQd » Sun Aug 15, 2021 5:42 am

Clear the cache in the app before you connect to the controller with your mobile device. Check the controller firmware before connecting to the aircraft. If the controller needs a firmware update, do it before connecting the drone.

Hope this helps,


Post Reply